Задание №6
ID: 194

Анализ программ с условным оператором и логическими выражениями

Подбор параметра в условии

Ниже приведена программа, записанная на пяти языках программирования.

Бейсик Python
DIM s, t, A AS INTEGER
INPUT s
INPUT t
INPUT A
IF s > A OR t > 9 THEN
    PRINT "YES"
ELSE
    PRINT "NO"
ENDIF
s = int(input())
t = int(input())
A = int(input())

if s > A or t > 9:
    print("YES")
else:
    print("NO")
Паскаль Алгоритмический язык
var s, t, A: integer;
begin
    readln(s);
    readln(t);
    readln(A);

    if (s > A) or (t > 9)
        then writeln('YES')
        else writeln('NO')
end.
алг
нач
цел s, t, A
ввод s
ввод t
ввод A

если s > A или t > 9
    то вывод "YES"
    иначе вывод "NO"
все
кон
C++
#include <iostream>
using namespace std;

int main() {
    int s, t, A;

    cin >> s;
    cin >> t;
    cin >> A;

    if (s > A || t > 9)
        cout << "YES";
    else
        cout << "NO";

    return 0;
}

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(-4, 7); (2, 9); (5, 3); (8, 10); (9, 6); (11, 1); (13, 9); (15, 4); (20, 8).

Укажите наименьшее целое значение параметра A, при котором для указанных входных данных программа напечатает «NO» ровно 6 раз.