Задание №16
ID: 400

Программирование: обработка последовательности чисел

Последовательность заканчивается числом 0

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4 и оканчивающихся на 2.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0. Число 0 является признаком окончания ввода и в последовательность не входит.

Программа должна вывести одно число: количество чисел, кратных 4 и оканчивающихся на 2.

Пример работы программы:

Входные данныеВыходные данные
12
24
32
42
18
0
2
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем первое число последовательности.
  2. Создаём список b, куда будем добавлять числа, которые делятся на 4 и оканчиваются на 2.
  3. Пока не встретился ноль, проверяем каждое введённое число.
  4. Если число подходит под условие, добавляем его в список с помощью append.
  5. В конце выводим количество подходящих чисел с помощью функции len.

Решение на Python:

a = int(input())  # считываем первое число
b = []  # создаём список для подходящих чисел

while a != 0:  # обрабатываем числа до нуля
    if a % 4 == 0 and a % 10 == 2:  # проверяем кратность 4 и последнюю цифру 2
        b.append(a)  # добавляем подходящее число в список

    a = int(input())  # считываем следующее число

print(len(b))  # выводим количество подходящих чисел