Задание №16
ID: 403

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, которые больше 50 и делятся на 7.

Программа получает на вход количество чисел в последовательности, затем сами числа. Количество чисел не превышает 1000, введённые числа не превышают 30 000.

Программа должна вывести одно число: количество чисел, которые больше 50 и делятся на 7.

Пример работы программы:

Входные данныеВыходные данные
6
14
56
70
49
105
12
3
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять числа, которые больше 50 и делятся на 7.
  3. Для каждого введённого числа проверяем оба условия.
  4. Если число подходит, добавляем его в список с помощью append.
  5. В конце выводим количество подходящих чисел с помощью функции len.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число

    if a > 50 and a % 7 == 0:  # проверяем, что число больше 50 и делится на 7
        b.append(a)  # добавляем подходящее число в список

print(len(b))  # выводим количество подходящих чисел