Задание №16
ID: 407

Программирование: обработка последовательности чисел

Количество чисел известно

Напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое чисел, кратных 4. Ответ нужно вывести с точностью до десятых.

Программа получает на вход количество чисел в последовательности, затем сами числа. Гарантируется, что в последовательности есть хотя бы одно число, кратное 4.

Программа должна вывести одно число: среднее арифметическое чисел, кратных 4.

Пример работы программы:

Входные данныеВыходные данные
5
8
12
7
20
5
13.3
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем количество чисел в последовательности.
  2. Создаём список b, куда будем добавлять только числа, которые делятся на 4.
  3. Для каждого введённого числа проверяем кратность 4.
  4. Если число подходит под условие, добавляем его в список с помощью append.
  5. В конце находим среднее арифметическое через sum(b) / len(b) и выводим результат с точностью до десятых.

Решение на Python:

n = int(input())  # считываем количество чисел
b = []  # создаём список для подходящих чисел

for i in range(n):  # повторяем ввод n раз
    a = int(input())  # считываем очередное число

    if a % 4 == 0:  # проверяем кратность 4
        b.append(a)  # добавляем подходящее число в список

print(round(sum(b) / len(b), 1))  # выводим среднее арифметическое с точностью до десятых