Задание №16
ID: 412

Программирование: обработка последовательности чисел

Последовательность заканчивается числом 0

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел. Ответ нужно вывести с точностью до десятых.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0. Число 0 является признаком окончания ввода и в последовательность не входит. В последовательности всегда имеется хотя бы одно двузначное число.

Программа должна вывести одно число: среднее арифметическое двузначных чисел.

Пример работы программы:

Входные данныеВыходные данные
8
14
100
36
7
0
19.3
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем первое число последовательности.
  2. Создаём список b, куда будем добавлять только двузначные числа.
  3. Пока не встретился ноль, проверяем каждое введённое число.
  4. Если число находится в диапазоне от 10 до 99, добавляем его в список с помощью append.
  5. После окончания ввода находим среднее арифметическое через sum(b) / len(b).
  6. В конце выводим результат с точностью до десятых.

Решение на Python:

a = int(input())  # считываем первое число
b = []  # создаём список для двузначных чисел

while a != 0:  # обрабатываем числа до нуля
    if 10 <= a <= 99:  # проверяем, что число двузначное
        b.append(a)  # добавляем двузначное число в список

    a = int(input())  # считываем следующее число

print(round(sum(b) / len(b), 1))  # выводим среднее арифметическое с точностью до десятых