Задание №16
ID: 416

Программирование: обработка последовательности чисел

Последовательность заканчивается числом 0

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, которые делятся на 7 и не делятся на 14.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0. Число 0 является признаком окончания ввода и в последовательность не входит.

Программа должна вывести одно число: сумму всех подходящих чисел.

Пример работы программы:

Входные данныеВыходные данные
7
14
21
28
35
8
0
63
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем первое число последовательности.
  2. Создаём список b, куда будем добавлять числа, которые делятся на 7 и не делятся на 14.
  3. Пока не встретился ноль, проверяем каждое введённое число.
  4. Если число подходит под условие, добавляем его в список с помощью append.
  5. В конце выводим сумму всех подходящих чисел с помощью функции sum.

Решение на Python:

a = int(input())  # считываем первое число
b = []  # создаём список для подходящих чисел

while a != 0:  # обрабатываем числа до нуля
    if a % 7 == 0 and a % 14 != 0:  # проверяем делимость на 7 и отсутствие делимости на 14
        b.append(a)  # добавляем подходящее число в список

    a = int(input())  # считываем следующее число

print(sum(b))  # выводим сумму подходящих чисел