Задание №16
ID: 418

Программирование: обработка последовательности чисел

Последовательность заканчивается числом 0

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, у которых произведение первой и последней цифры делится на 2.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0. Число 0 является признаком окончания ввода и в последовательность не входит.

Программа должна вывести одно число: количество подходящих чисел.

Пример работы программы:

Входные данныеВыходные данные
123
57
48
91
26
0
3
Задание выполняется на компьютере. После выполнения можно посмотреть решение.

Решение

Идея решения:

  1. Считываем первое число последовательности.
  2. Создаём список b, куда будем добавлять числа, у которых произведение первой и последней цифры делится на 2.
  3. Пока не встретился ноль, для каждого числа находим первую и последнюю цифру.
  4. Если произведение первой и последней цифры чётное, добавляем число в список с помощью append.
  5. В конце выводим количество подходящих чисел с помощью функции len.

Решение на Python:

a = int(input())  # считываем первое число
b = []  # создаём список для подходящих чисел

while a != 0:  # обрабатываем числа до нуля
    first = int(str(a)[0])  # находим первую цифру числа
    last = a % 10  # находим последнюю цифру числа

    if (first * last) % 2 == 0:  # проверяем чётность произведения первой и последней цифры
        b.append(a)  # добавляем подходящее число в список

    a = int(input())  # считываем следующее число

print(len(b))  # выводим количество подходящих чисел