⚠️ Сайт в разработке. По всем вопросам — Telegram: @nikitainf0rm
Задание №16
ID: 57

Алгоритмы и программирование

Обработка последовательностей чисел: циклы, условия, суммы, максимумы и среднее арифметическое

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число  — максимальное число, кратное 5.

 

Пример работы программы:

Входные данныеВыходные данные

3

10

25

12

25
Задание выполняется на компьютере.

Решение

Решение на Python 

arr=[]
a=int(input())
for i in range(a):
    x=int(input())
    if x%5==0:
        arr.append(x)
print(max(arr))