⚠️ Сайт в разработке. По всем вопросам — Telegram: @nikitainf0rm
Задание №16
ID: 58

Алгоритмы и программирование

Обработка последовательностей чисел: циклы, условия, суммы, максимумы и среднее арифметическое

Напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших. Программа должна вывести две этих суммы в указанном порядке. Программа получает на вход целые числа, количество введенных чисел не известно, последовательность чисел заканчивается числом 0 (0  — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.

В последовательности не менее двух чисел.

 

Пример работы программы:

Входные данныеВыходные данные

3

10

25

12

0

37

13

Задание выполняется на компьютере.

Решение

Решение на Python

arr=[]
a=int(input())
while a!=0:
    arr.append(a)
    a = int(input())
arr.sort()
print(arr[-1]+arr[-2])
print(arr[0]+arr[1])